Clignotement des feux avec décodeur ESU et centrale ECOS:

Les commandes numériques du réseau (appelées à tort "digitales") sont l'avenir du train miniature. Mais comment choisir, comment sauter le pas, avec ou sans ordinateur ? Autant de questions dont les réponses se trouvent dans l'expérience des uns et des autres…

Modérateur : MOD

PATVMX
Démonstratif
Messages : 1408
Enregistré le : jeu. 08 janv. 2009, 16:17
Localisation : 90
Âge : 62

Clignotement des feux avec décodeur ESU et centrale ECOS:

Message par PATVMX » mar. 09 oct. 2018, 20:30

J'ai installé un Loksound V4 sur une 36000 Champagnole équipée de feux d'extrémité à lampes.
Tout fonctionne parfaitement à une exception: les feux émettent un petit clignotement régulier à 1 ou 2 Hz que je suis incapable de supprimer.
Ceci ne se produit qu'avec ma centrale ECOS 2, le problème n'existe pas avec ma Multimaus ni avec le Lokprogrammer.
Je précise qu'il ne s'agit pas d'un problème de réglage du nombre de crans 14/28/128.

J'ai changé l'alim de l'ECOS, fait varier le niveau de tension, changé la butée de courant, j'ai également fait varier le niveau de tension de la sortie auxiliaire, supprimé le dimmer, etc... rien n'y fait.
Toutes mes autres locos ne présentent pas le problème à l'exception d'une 67000 HJ qui clignote elle aussi lorsque les ventilos tournent. Là encore, c'est uniquement avec l'ECOS et pas avec d'autres centrales.... :colere:

Alors si quelqu'un a une idée, je suis preneur...

PATVMX
Démonstratif
Messages : 1408
Enregistré le : jeu. 08 janv. 2009, 16:17
Localisation : 90
Âge : 62

Re: Clignotement des feux avec décodeur ESU et centrale ECOS

Message par PATVMX » mer. 10 oct. 2018, 14:55

Je m'auto-réponds... :ange3:

Le clignotement lent et très régulier me faisait penser à un "battement", phénomène bien connu en électronique.
En regardant la platine Jouef Champagnole, je me suis aperçu que le fil bleu du retour commun des sorties AUX n'était pas câblé sur la prise 8 broches. Le retour des lampes se fait par le retour châssis (fil noir).
En câblant le fil bleu, le phénomène a disparu.
Ceci veut dire que le potentiel de la sortie AUX fluctue si l'on n'utilise pas le retour fil bleu dédié, l'alimentation étant alors "flottante".

Pourquoi le problème ne se voit-il qu'avec l'ECOS ?
L'explication probable est que la composante continue présente dans le signal DCC est probablement un peu différente de celle de la Multimaus ou du Lokpro. (Je n'ai pas sorti l'oscillo pour vérifier. :oops: )

Reste à voir le cas de la 67000, j'imagine quelque chose du même genre.

Voilà, j'ai fini de vous saouler avec ce post, si ça peut aider quelqu'un...

Avatar du membre
Prevost
Mon surnom à moi
Messages : 26834
Enregistré le : lun. 02 janv. 2006, 10:04
Echelle pratiquée : H0.fr & H0.usa
Prénom : Alain
Localisation : Au pays des lentilles AOP
Âge : 65

Re: Clignotement des feux avec décodeur ESU et centrale ECOS

Message par Prevost » mer. 10 oct. 2018, 15:10

Le retour direct à la voie fait qu'on est sur une demi alternance du courant alternatif. Donc demi-tension effective et alternance de tension max et de zéro. Il a risque de scintillement voir de clignotement.
Par ailleurs, il n'y a pas de composante continue sur le signal DCC. Ou alors on ne parle pas de la même chose. :wink:

Avatar du membre
PJRo
Zé cru voir un rominet!
Messages : 13952
Enregistré le : lun. 15 août 2005, 17:45
Echelle pratiquée : HO
Prénom : Pascal
Club : MSL (MecSuperLent)
Site Internet : http://ferromodelnumdcc.monsite-orange.fr/
Âge : 63

Re: Clignotement des feux avec décodeur ESU et centrale ECOS

Message par PJRo » mer. 10 oct. 2018, 16:16

Je vais peut-être dire une connerie mais j'ose :

Le coup du fil bleu ajouté au fait qu'on utilise un décodeur multi-protocole avec une centrale elle aussi multi-protocole y est peut-être pour quelque-chose, non ?

PATVMX
Démonstratif
Messages : 1408
Enregistré le : jeu. 08 janv. 2009, 16:17
Localisation : 90
Âge : 62

Re: Clignotement des feux avec décodeur ESU et centrale ECOS

Message par PATVMX » mer. 10 oct. 2018, 16:19

Prevost a écrit :Le retour direct à la voie fait qu'on est sur une demi alternance du courant alternatif. Donc demi-tension effective et alternance de tension max et de zéro. Il a risque de scintillement voir de clignotement.
Pour la demi-tension efficace, c'est vrai mais ce n'est pas la raison qui explique le scintillement: j'avais une demi-tension de 8,5V, j'ai réglé à nouveau cette même valeur après recâblage.
Prevost a écrit : Par ailleurs, il n'y a pas de composante continue sur le signal DCC. Ou alors on ne parle pas de la même chose. :wink:
En théorie, la valeur moyenne est bien nulle: en pratique, les imperfections des composants font que ce n'est pas tout à fait le cas.

As-tu une autre hypothèse d'explication ?

PATVMX
Démonstratif
Messages : 1408
Enregistré le : jeu. 08 janv. 2009, 16:17
Localisation : 90
Âge : 62

Re: Clignotement des feux avec décodeur ESU et centrale ECOS

Message par PATVMX » mer. 10 oct. 2018, 16:22

PJRo a écrit :Je vais peut-être dire une connerie mais j'ose :

Le coup du fil bleu ajouté au fait qu'on utilise un décodeur multi-protocole avec une centrale elle aussi multi-protocole y est peut-être pour quelque-chose, non ?
Mon décodeur n'est pas multi-protocole, c'est le V4 DCC.

belledone
Disert
Messages : 481
Enregistré le : mer. 28 avr. 2010, 16:56
Localisation : ALPES

Re: Clignotement des feux avec décodeur ESU et centrale ECOS

Message par belledone » mer. 10 oct. 2018, 17:56

Le DCC n'a pas de composante continue. Le motorola a une composante DC variable selon le code envoyé. L'ECOS a la possibilité, je crois, d'envoyer à la fois du DCC et du Mota. Si cette possibilité n'est pas mise sur "off", le signal sur la voie est mixte, et a donc une composante DC variable.
Cordialement,

PATVMX
Démonstratif
Messages : 1408
Enregistré le : jeu. 08 janv. 2009, 16:17
Localisation : 90
Âge : 62

Re: Clignotement des feux avec décodeur ESU et centrale ECOS

Message par PATVMX » mer. 10 oct. 2018, 19:46

@ belledone:

Bingo, c'est le protocole Märklin Mfx (hérité du Motorola ?) dénommé M4 sur l'Ecos qui génère la composante continue à l'origine du clignotement.
En décochant "M4", une loco avec retour éclairage au rail cesse de scintiller.

J'ai sorti l'oscillo, j'ai mesuré 0,4V de composante continue sur la trame en DCC pur , mais ce n'est pas ça qui gêne.

Il va falloir que je passe ma 241A Trix en DCC car elle ne fonctionne plus en désactivant le Mfx / M4.

Merci pour cette intervention.

Avatar du membre
Prevost
Mon surnom à moi
Messages : 26834
Enregistré le : lun. 02 janv. 2006, 10:04
Echelle pratiquée : H0.fr & H0.usa
Prénom : Alain
Localisation : Au pays des lentilles AOP
Âge : 65

Re: Clignotement des feux avec décodeur ESU et centrale ECOS

Message par Prevost » mer. 10 oct. 2018, 23:11

Je ne sais pas ce que mesure ton oscilloscope mais je ne vois pas ou il peut y avoir une composante continue dans un courant DCC.
Image
Fichiers joints
Capture4.PNG

Avatar du membre
Deimos_epIV
Intarissable !
Messages : 8674
Enregistré le : ven. 23 déc. 2011, 21:25
Echelle pratiquée : HO/DCC
Prénom : Claude
Club : MMF
Localisation : Montpellier (34)
Âge : 61

Re: Clignotement des feux avec décodeur ESU et centrale ECOS

Message par Deimos_epIV » jeu. 11 oct. 2018, 01:33

Dissymétrie entre les amplificateurs hauts et bas. 0,4 V n'est rien de choquant tant qu'il n'est pas fait usage de transistors parfaitement appairés. Il est possible de supprimer cet offset, du moins le diminuer encore, avec un peu d'électronique. Sans doute que ESU ne l'a pas jugé utile. Je dis bien "sans doute" parce que je n'en sais rien, n'ayant pas les schémas.
Amicalement

PATVMX
Démonstratif
Messages : 1408
Enregistré le : jeu. 08 janv. 2009, 16:17
Localisation : 90
Âge : 62

Re: Clignotement des feux avec décodeur ESU et centrale ECOS

Message par PATVMX » jeu. 11 oct. 2018, 13:59

Prevost a écrit :Je ne sais pas ce que mesure ton oscilloscope mais je ne vois pas ou il peut y avoir une composante continue dans un courant DCC.
Connaissant ton fonctionnement, j'étais certain que tu contesterais ce que j'ai fait. :wink:
Je ne suis pas tout à fait novice en mesures et je peux te certifier qu'entre ta belle trame théorique et la réalité il y a parfois tout un monde. Et ceci n'empêche pas le matériel de fonctionner.
Mon oscillo est à quatre traces: chaque voie donne le même offset, on peut toujours dire que les 4 amplis verticaux présentent la même panne, mébon... :)

Avatar du membre
Prevost
Mon surnom à moi
Messages : 26834
Enregistré le : lun. 02 janv. 2006, 10:04
Echelle pratiquée : H0.fr & H0.usa
Prénom : Alain
Localisation : Au pays des lentilles AOP
Âge : 65

Re: Clignotement des feux avec décodeur ESU et centrale ECOS

Message par Prevost » jeu. 11 oct. 2018, 14:26

Je ne comprends pas ta réaction. :? Je ne conteste pas, je cherche à comprendre.
Maintenant si tu ne souhaites pas de discutions suite à tes questions, je te prie de m'excuser pour mes interventions. :(

PATVMX
Démonstratif
Messages : 1408
Enregistré le : jeu. 08 janv. 2009, 16:17
Localisation : 90
Âge : 62

Re: Clignotement des feux avec décodeur ESU et centrale ECOS

Message par PATVMX » jeu. 11 oct. 2018, 14:44

Donc, on va dire que je me suis mépris sur le ton que tu utilises et de ce fait il n'y a pas de problème pour continuer à discuter. :wink:

Avatar du membre
Prevost
Mon surnom à moi
Messages : 26834
Enregistré le : lun. 02 janv. 2006, 10:04
Echelle pratiquée : H0.fr & H0.usa
Prénom : Alain
Localisation : Au pays des lentilles AOP
Âge : 65

Re: Clignotement des feux avec décodeur ESU et centrale ECOS

Message par Prevost » jeu. 11 oct. 2018, 15:05

As tu les moyens, à l'occasion, de faire une photo de l'écran de ton oscilloscope :?: C'est juste pour mon information.

PATVMX
Démonstratif
Messages : 1408
Enregistré le : jeu. 08 janv. 2009, 16:17
Localisation : 90
Âge : 62

Re: Clignotement des feux avec décodeur ESU et centrale ECOS

Message par PATVMX » jeu. 11 oct. 2018, 15:24

Oui, je ferai ça à l'occasion car pour l'instant j'ai rangé tout le fourbi. J'en profiterai pour photographier une trame Märklin Mfx/M4 .

Répondre