Forums LR PRESSE

Où il est question de trains, petits et grands

  • Advertisement

Démarrage

Toutes les discussions sur l'Arduino !

Modérateur: MOD

Démarrage

Publié: Mar 29 Août 2017, 14:06 
Bonjour à tous

Arduino, Arduino ! Ici on a affaire à des experts, pour qui aligner des pages d'instructions et de programmes est routine ! :lol:

Mais il y a aussi des profanes qui "voudraient bien s'y mettre" et là, c'est pas gagné :cry:

Toutes les pages "d'initiation" sont, bien sur, accessibles, et permettent de démarrer "petitement".

J'ai donc déballé un kit Uno, reçu il y a déjà quelques temps, mais non utilisé jusqu'alors, faute de temps (quelqu'un, sur ce forum, parlait de journées de 48 heures, mais serait-ce suffisant ?), chargé l'IDE sur mon PC, compilé un tout petit programme (commande d'un servo par un potentiomètre), et essayé de transférer ce prog dans l'Arduino.

Mais à la mise sous tension (par le cordon USB) le voyant "On" sur la carte et ok, mais la led "L" clignote dès la mise sous tension et ne s’arrête pas. Le bouton "reset" sur la carte éteint momentanément, puis rallume, toujours en clignotant, cette led "L"

Dans les forums, je n'ai rien trouvé concernant la phase "Que se passe t-il à la mise en route du module", qui,à première vue, n'est pas abordée, surement est-ce évident pour la plupart d'entre-nous, mais moi, je bloque la dessus :siffle:

Si je veux aller plus loin (et c'est le but !) Help me !

Merci pour tous ces articles qui m'encouragent à m'y coller ! :applause:
Avatar de l’utilisateur
05mogul05
Bavard
 
Messages: 61
Inscrit le: Lun 01 Fév 2010, 20:31
Localisation: GARD
Âge: 70

Re: Démarrage

Publié: Mar 29 Août 2017, 17:43 
Petite avancée:

Bibliothèques non conformes et drivers pas au top ! (comme moi !)

Maintenant mon cerveau servo réagit a la position du potentiomètre :ange:
Avatar de l’utilisateur
05mogul05
Bavard
 
Messages: 61
Inscrit le: Lun 01 Fév 2010, 20:31
Localisation: GARD
Âge: 70

Re: Démarrage

Publié: Mar 29 Août 2017, 19:57 
La LED L correspond à la broche 13 (simple recopie). Par défaut les ARDUINO sont chargés avec le programme "Blink" qui fait clignoter cette LED. C'est donc tout à fait normal.

Si tu as des problèmes pour téléverser un programme, commence simple en ouvrant le programme "Blink" qui est dans les exemples de l'IDE et modifie la fréquence de clignotement (voir le fil d'initiation "Démarrer en électronique programmable : http://forum.e-train.fr/viewtopic.php?f=63&t=80539)
Avatar de l’utilisateur
Gugus
Fécond
 
Messages: 562
Inscrit le: Jeu 15 Oct 2009, 19:50
Localisation: Versailles (78)
Âge: 32
Echelle pratiquée: HO

Re: Démarrage

Publié: Mar 29 Août 2017, 22:06 
05mogul05 a écrit:Bonjour à tous

Arduino, Arduino ! Ici on a affaire à des experts, pour qui aligner des pages d'instructions et de programmes est routine ! :lol:

Mais il y a aussi des profanes qui "voudraient bien s'y mettre" et là, c'est pas gagné :cry:



Pour les profanes qui voudraient bien s'y mettre, le site LOCODUINO est certainement le meilleur endroit pour débuter. On y trouve des données sur les cartes Arduino, comment installer et utiliser au mieux le logiciel de programmation, comment faire ses premiers programmes, et comment réaliser de petites animations pour votre réseau.

Ensuite, on peut se perfectionner en apprenant les rudiments du "langage" d'Arduino, les fameuses fonctions puis comment utiliser des bibliothèques.

Enfin, des projets plus sérieux (plus musclés !) sont aussi là pour vous apprendre à faire des automatismes, remplacer des composants électroniques par des pages internet, dessiner et exploiter votre réseau.

Comme pour tout apprentissage, il faut aller du plus simple au plus compliqué, jamais l'inverse !

Pour cette fameuse LED 13 qui clignote à la mise en route, Gugus a répondu.

Et si malgré tout cela, tu as encore des soucis, il y a notre forum (sur Locoduino) qui te permet de trouver de l'aide. Et aussi ce forum puisqu'on y est présent.

Pas belle la vie ? :wink:
Bonnes réalisations !
Avatar de l’utilisateur
Arduino
Prolixe
 
Messages: 1616
Inscrit le: Mer 25 Sep 2013, 17:14

Re: Démarrage

Publié: Mar 29 Août 2017, 22:09 
05mogul05 a écrit:Petite avancée:

Bibliothèques non conformes et drivers pas au top ! (comme moi !)

Maintenant mon cerveau servo réagit a la position du potentiomètre :ange:


Juste une question : ton Arduino est d'origine ou bien un clone d'Asie ? Cela pourrait expliquer le problème de driver...

Je te rassure, tout ce résout ... mais c'est plus facile de débuter avec un module de marque Arduino/Genuino (non, je ne suis pas payé par eux pour dire cela :lol: ).
Avatar de l’utilisateur
Arduino
Prolixe
 
Messages: 1616
Inscrit le: Mer 25 Sep 2013, 17:14

Re: Démarrage

Publié: Mar 29 Août 2017, 23:21 
Gugus a écrit:La LED L correspond à la broche 13 (simple recopie). Par défaut les ARDUINO sont chargés avec le programme "Blink" qui fait clignoter cette LED. C'est donc tout à fait normal.yy


Merci Gugus ! :ange:
Ce programme "Blink" de base a été remplacé par le prog "Servo" et tout fonctionne :ange3:

Arduino a écrit:
Pour les profanes qui voudraient bien s'y mettre, le site LOCODUINO est certainement le meilleur endroit pour débuter. On y trouve des données sur les cartes Arduino, comment installer et utiliser au mieux le logiciel de programmation, comment faire ses premiers programmes, et comment réaliser de petites animations pour votre réseau.


C'est la démarche que j'ai en ce moment, et je découvre, petit à petit, les notions de base INDISPENSABLES pour comprendre la suite :siffle:

merci pour ces réponses :applause:
Avatar de l’utilisateur
05mogul05
Bavard
 
Messages: 61
Inscrit le: Lun 01 Fév 2010, 20:31
Localisation: GARD
Âge: 70

Re: Démarrage

Publié: Mar 29 Août 2017, 23:29 
Arduino a écrit:Juste une question : ton Arduino est d'origine ou bien un clone d'Asie ? Cela pourrait expliquer le problème de driver...



ARDUINO UNO R3 acheté sur un site de grande diffusion, mais estampillé "made in Italy"
Avatar de l’utilisateur
05mogul05
Bavard
 
Messages: 61
Inscrit le: Lun 01 Fév 2010, 20:31
Localisation: GARD
Âge: 70

Re: Démarrage

Publié: Mar 29 Août 2017, 23:47 
Bravo pour avoir réussi à faire fonctionner Servo ; c'est un début et d'autres victoires suivront et petit à petit, tu apprendras à commander tout un tas d'objets (servos, moteurs, écran, etc.). De quoi bien s'amuser ! Trouver une utilisation pour le train est alors facile.

Pour le module, si le nom Arduino ou Genuino est écrit sur le circuit imprimé, c'est un module d'origine. S'il y a seulement la référence UNO R3 (qui n'est pas un nom de marque), le module est sans doute un clone. Parfois, ceux-ci sont conçus autour de circuits intégrés différents ; ils fonctionnent très bien à condition d'utiliser les bons drivers. Pour quelqu'un de confirmé, c'est facile à faire. Cela peut complètement décourager un débutant qui n'arrive pas à faire fonctionner son module alors qu'il a lu partout que c'était hyper simple : raison pour laquelle nous conseillons toujours un module d'origine.

Mais maintenant que tu as réussi à faire fonctionner le programme Servo, il n'y aura plus de problème pour toi ; d'après ce que tu dis, tu as un module d'origine.
Avatar de l’utilisateur
Arduino
Prolixe
 
Messages: 1616
Inscrit le: Mer 25 Sep 2013, 17:14


Retour vers Arduino

Qui est en ligne ?

Utilisateur(s) parcourant actuellement ce forum : Aucun utilisateur inscrit et 3 invité(s)