TCO Xpressnet

Toutes les discussions sur l'Arduino !

Modérateur : MOD

sam95
Messages : 26
Enregistré le : mar. 17 nov. 2009, 11:27
Site Internet : http://sam95.fr
Localisation : Ermont 95
Âge : 39

TCO Xpressnet

Message par sam95 » lun. 13 févr. 2017, 19:59

Bonjour,

Voila j'ai réalisé un TCO à base d'arduino, il se branche sur la borne slave de la roco multimaus. J'ai suivit le tutoriel disponible sur le site de l'UAICF nevers vauzelles
http://modelisme58.free.fr/index.php/arduino.html

Voici ce que ça donne:



Pour plus de détails j'ai écris un article concernant la réalisation sur mon site:
http://www.sam95.fr/?p=1029

Si ça peut servir à d'autres, c'est un montage facile à réaliser et qui fonctionne bien.

Avatar du membre
Prevost
Mon surnom à moi
Messages : 27256
Enregistré le : lun. 02 janv. 2006, 10:04
Echelle pratiquée : H0.fr & H0.usa
Prénom : Alain
Localisation : Au pays des lentilles AOP
Âge : 66

Re: TCO Xpressnet

Message par Prevost » lun. 13 févr. 2017, 20:17

:applause: :applause:

Plume
Bavard
Messages : 68
Enregistré le : jeu. 02 juil. 2015, 22:18
Echelle pratiquée : HO
Club : UAICF Nevers Vauzelles
Site Internet : http://modelisme58.free.fr
Localisation : Nevers

Re: TCO Xpressnet

Message par Plume » jeu. 16 févr. 2017, 12:44

Bonjour,

Belle mise en oeuvre. Félicitations pour la présentation.
On retrouve l'utilisation des boutons avec un pupitre DCC et avec 4 fils...

Le protocole XpressNet utilisé pour ce projet est un bus de commande utilisé notamment par les centrales Atlas, Lenz, Hornby, OpenDCC, Paco Canada, ZTC Controls, Viessmann, et Roco.

Ce TCO est compatible avec les centrales Roco 10761, 10764, Z21, Viessmann Commander, …

Avatar du membre
FFayolle
Éloquent
Messages : 383
Enregistré le : mar. 09 mai 2006, 19:55
Localisation : Amiens, Somme, Picardie
Âge : 52

Re: TCO Xpressnet

Message par FFayolle » dim. 26 févr. 2017, 13:28

Interesting!!!
:applause: :applause: :applause:

Et l'interface Arduino XPressNet me semble très simple comparée à celle pour LocoNet.
Fabrice Fayolle

PBL91
Bavard
Messages : 61
Enregistré le : mer. 27 sept. 2006, 17:38
Localisation : Dammartin

Re: TCO Xpressnet

Message par PBL91 » ven. 19 mai 2017, 18:26

Bonjour,

L'arduino communique bien avec la centrale
DCC=255 hors connexion
DCC=2 arret urgence
DCC=0 signal dcc sur voie
mais je n'envoie pas de commande aux aiguillages(sdec-4) sur centrale roco ampli 10764 et lokmaus2
je me rappel il y a un moment de ça ,qu'il y avait un decalage dans les adresses de depart suivant les centrales ,ou j'ai un bug dans le programme
si quelqu'un à déjà rencontre le même problème a t'il trouve une solution ?
Merci et bon Train
PBL.

Plume
Bavard
Messages : 68
Enregistré le : jeu. 02 juil. 2015, 22:18
Echelle pratiquée : HO
Club : UAICF Nevers Vauzelles
Site Internet : http://modelisme58.free.fr
Localisation : Nevers

Re: TCO Xpressnet

Message par Plume » sam. 20 mai 2017, 20:47

Bonjour,

Il y a effectivement un décalage avec certaines centrales : décalage d'une adresse ou les adresses 1 à 4 non reconnues.

Pour le savoir, un scanner de trames DCC peut être très utile. Voici un lien sur la base d'un Arduino : http://modelisme58.free.fr/index.php/arduino.html

PS : La prochaine souris XpressNet proposée sera sans fil, en infrarouge, dans une boite en contreplaqué de 5 mm découpé au laser. Son nom de code : "Xpse-IR". On pilote les locos et les accessoires avec sa télécommande de TV. Tout fonctionne, il reste juste à finaliser le tutoriel...

La librairie XpressNet offre de nombreuses possibilités : lors de l'exposition à Saint-Germain-des-Fossés (03) fin avril, un TGV à l'échelle Ho était piloté avec un vrai pupitre de TGV.
Image
Fichiers joints
pupitre_TGV.jpg
pupitre_TGV.jpg (54.64 Kio) Vu 10655 fois

PBL91
Bavard
Messages : 61
Enregistré le : mer. 27 sept. 2006, 17:38
Localisation : Dammartin

Re: TCO Xpressnet

Message par PBL91 » sam. 20 mai 2017, 21:06

Bonsoir,

Merci Plume
Justement je pensais à ce site pour realiser le scanner de trames dcc
PBL.

Avatar du membre
DeepPurple
Loquace
Messages : 1010
Enregistré le : ven. 04 nov. 2016, 19:36
Echelle pratiquée : N/DCC
Prénom : Philippe
Club : AMFB Braine-l'Alleud (B)
Site Internet : http://pdf.cachalo.be
Localisation : Un peu plus à l'ouest
Âge : 64

Re: TCO Xpressnet

Message par DeepPurple » sam. 12 août 2017, 09:44

@Plume Le site que tu as référencé est une mine d'informations. Un grand merci ! ("Voici un lien sur la base d'un Arduino : http://modelisme58.free.fr/index.php/arduino.html")
Loch & LOL !

Avatar du membre
12035
Démonstratif
Messages : 1500
Enregistré le : lun. 08 déc. 2008, 13:20

Re: TCO Xpressnet

Message par 12035 » sam. 12 août 2017, 11:23

Bonjour,
Merci pour le partage :applause:
@+
12035

VNS-87
Causant
Messages : 233
Enregistré le : dim. 30 mars 2014, 20:05
Echelle pratiquée : HO
Club : Lille modelisme
Localisation : Lille

Re: TCO Xpressnet

Message par VNS-87 » mar. 15 août 2017, 10:07

Bonjour;

je vais réaliser ce montage pour la commande de mes servos moteur sur mon réseau industriel. si j'ai bien compris comme je vais utiliser des interrupteur à levier, 20 entrées + la masse seront occupés . d'ou ma question est-il possible d'utiliser les sorties restante pour une retrosignalisation sur un TCO via 2 LED?

Plume
Bavard
Messages : 68
Enregistré le : jeu. 02 juil. 2015, 22:18
Echelle pratiquée : HO
Club : UAICF Nevers Vauzelles
Site Internet : http://modelisme58.free.fr
Localisation : Nevers

Re: TCO Xpressnet

Message par Plume » ven. 18 août 2017, 22:18

Bonjour,

Pour les sorties restantes sur l'Arduino MEGA, on peut bien entendu les utiliser pour piloter des LED.

Attention, on est limité en intensité : on ne pourra pas allumer 20 LED depuis les sorties de l'Arduino.

Je propose d'utiliser un composant qui fait du multiplexage : 74HC595 ou 74LS595. Il y a un tutoriel pour sa mise en oeuvre sur le site http://eskimon.fr/269-arduino-annexe-1- ... no-74hc595. Et là en plus on résolut le problème d'alimentation.

En utilisant 3 sorties de l'Arduino, on peut commander séparément jusqu'à 64 LEDS de mémoire. Chaque composant alimente 8 LED. En mettant en série plusieurs composants, on augmente le nombre de LED pilotées.

Il y a un exemple de multiplexage pour la commande d'aiguillages sur le site : http://modelisme58.free.fr/index.php/arduino.html (aller en bas de la page pour voir les décodeurs d'accessoires avec un Arduino).

Avatar du membre
DeepPurple
Loquace
Messages : 1010
Enregistré le : ven. 04 nov. 2016, 19:36
Echelle pratiquée : N/DCC
Prénom : Philippe
Club : AMFB Braine-l'Alleud (B)
Site Internet : http://pdf.cachalo.be
Localisation : Un peu plus à l'ouest
Âge : 64

Re: TCO Xpressnet

Message par DeepPurple » sam. 19 août 2017, 08:46

Quelle mine d'infos, le blog d'Eskimon ! De la lecture pour des semaines. Un grand merci.
Loch & LOL !

Avatar du membre
12035
Démonstratif
Messages : 1500
Enregistré le : lun. 08 déc. 2008, 13:20

Re: TCO Xpressnet

Message par 12035 » dim. 20 août 2017, 07:14

+1
Merci :applause:
@+
12035

VNS-87
Causant
Messages : 233
Enregistré le : dim. 30 mars 2014, 20:05
Echelle pratiquée : HO
Club : Lille modelisme
Localisation : Lille

Re: TCO Xpressnet

Message par VNS-87 » dim. 25 févr. 2018, 12:43

Bonjour,

J’ai réalisé le montage mais j’ai un petit soucis peut être quelqu'un aura la réponse à mon problème.

Lorsque je modifie la position de l’aiguillage via la commande Roco l’aiguillage bouge.
lorsque j’actionne le levier l’état de l’aiguillage change sur la central mais pas sur le réseau.

d'ou pourrais venir le problème ?

Plume
Bavard
Messages : 68
Enregistré le : jeu. 02 juil. 2015, 22:18
Echelle pratiquée : HO
Club : UAICF Nevers Vauzelles
Site Internet : http://modelisme58.free.fr
Localisation : Nevers

Re: TCO Xpressnet

Message par Plume » lun. 26 févr. 2018, 23:01

Bonjour,

Attention, il peut y avoir un décalage d'une unité entre l'adresse saisie et celle traduite par la centrale.

Pour le vérifier, on peut utiliser un analyseur de trames DCC. On trouve sur le site http://modelisme58.free.fr/index.php/arduino.html un programme Arduino.

Répondre