Rétrosignalisation Roco, Digikeijs

Les commandes numériques du réseau (appelées à tort "digitales") sont l'avenir du train miniature. Mais comment choisir, comment sauter le pas, avec ou sans ordinateur ? Autant de questions dont les réponses se trouvent dans l'expérience des uns et des autres…

Modérateur : MOD

Répondre
Avatar du membre
Pat06
Messages : 10
Enregistré le : mer. 20 nov. 2019, 19:25
Echelle pratiquée : N
Prénom : Pat
Club : AMFN
Localisation : Sud Est

Rétrosignalisation Roco, Digikeijs

Message par Pat06 » mar. 14 janv. 2020, 14:51

Bonjour à tous,
Quand on a pas de DR5000 ainsi que le panneau de réglages sur PC ad hoc de chez Digikeijs, que l'on a seulement une z21 Start avec le panneau de maintenance Roco, comment sait on vraiment que le module de rétrosignalisation BR4088DR-CS à bien enregistré l'adresse que je lui ai "inoculé" ! :D
Non allez plutôt je dirais " transmise"...
(Je l'ai fait par le panneau "maintenance tools" de chez Roco car avec la" Multimaus rouge", ça ne fonctionne pas.)
Et sur mon nouveau logiciel de gestion Windigipet, il ne se passe rien sur le TCO, alors que les leds sur les modules même, détectent bien la présence des locos !
A noter que les Digikeijs 4088 ont 2 X 8 connecteurs et n'ont pas de détection visuelle individuelle par canton comme sur les Roco 10808.
Seule la led rouge s'éclaire quand une loco se trouve sur un des 16 cantons mais on ne sait pas lequel...
Leur témoin d'enregistrement par une seule led verte qui clignote de 2 fréquences différentes selon que l'on soit en mode programmation ou pas n'est vraiment pratique visuellement à définir. Il aurait été plus judicieux de placer une autre led pour confirmer le bon enregistrement ! :roll:
Voilou voilou, si quelqu'un à une idée, elle sera le bienvenue.
Pat.

Avatar du membre
Coquelicot94
Expansif
Messages : 2365
Enregistré le : lun. 02 janv. 2006, 17:21
Echelle pratiquée : H0
Localisation : Maroeuil (62)
Âge : 67

Re: Rétrosignalisation Roco, Digikeijs

Message par Coquelicot94 » mar. 14 janv. 2020, 15:34

Bonjour, il s'agit du module DR 4088 RB CS ? Quelle adresse lui as tu donné, y a t-il un autre module avant ou après ?
Je viens d'essayer avec une z21 start, un routeur TP Link, une liaison ordi et le logiciel de maintenance z21, à l'onglet RBus tu peux voir apparaitre tous les modules et savoir lequel est actif, avec quelle adresse en déplaçant ta loco...ou avec le doigts :wink:
A+
HO, N, Roco MMpro, zZ21, TC V9

philho
Éloquent
Messages : 310
Enregistré le : lun. 01 févr. 2010, 19:00

Re: Rétrosignalisation Roco, Digikeijs

Message par philho » mar. 14 janv. 2020, 16:31

De mémoire, la LED arrête de clignoter quand le DR4088RB-CS a bien reçu la programmation.
Attention : la première version de la notice du DR4088RB-CS était complètement pourrie: bien récupérer la dernière version.

L'état des entrées est bien visible sur l'outils de maintenance de la z21, mais attention il y a quelques "particularités" du R-bus à bien avoir en tète:

- les modules connectés sur le bus R-Bus doivent obligatoirement commencer à l'adresse 1 et avoir des adresses consécutives: 1-2-3 (par ex).
- les modules DR40088 utilises 2 adresses R-bus (1 adresse = 8 entrées)
- la z21 est très longue à reconnaître un nouveau module: il est fort possible de devoir attendre plusieurs dizaines de secondes avoir de voir le module sur l'outils de maintenance et/ou le logiciel de gestion de train.
- il faut impérativement un changement d'état sur chacun de 2 groupes de 8 entrées pour avoir le modules affiché sur le logiciel de maintenance.

Avatar du membre
Coquelicot94
Expansif
Messages : 2365
Enregistré le : lun. 02 janv. 2006, 17:21
Echelle pratiquée : H0
Localisation : Maroeuil (62)
Âge : 67

Re: Rétrosignalisation Roco, Digikeijs

Message par Coquelicot94 » mar. 14 janv. 2020, 17:37

Je constate la même chose que Pat06, quand le module 4088RB est sur l'adresse 1, il y a lecture des occupations sur l'outil de maintenance Roco Rbus à l'adresse 1 et 2, après prog à l'adresse 3, plus rien...Même en attendant assez longtemps .
En reprogrammant l'adresse 1 lecture à nouveau...
A+
HO, N, Roco MMpro, zZ21, TC V9

Avatar du membre
Pat06
Messages : 10
Enregistré le : mer. 20 nov. 2019, 19:25
Echelle pratiquée : N
Prénom : Pat
Club : AMFN
Localisation : Sud Est

Re: Rétrosignalisation Roco, Digikeijs

Message par Pat06 » mar. 14 janv. 2020, 19:47

Bonsoir,
Merci Coquelicot94 pour ces infos. :)

Mon 1er module connecté à la centrale "z21 Start" est un Digikeijs DR 4088RB-CS ensuite un second Digikeijs, puis vient à la suite 3 Roco 10808.
J'ai bien adressé (au moins 10 fois) l'adresse 1 sur le 1er module, ensuite j'appuie 2 fois sur la touche du même module pour ouvrir la programation de la 2ème partie de ce module ( puisque 2X8 connecteurs). Ensuite je fais adresse 3 sur le second module et adresse 4 toujours sur le second module, ensuite les Roco j'adresse 5, 6 et 7. (56 cantons max).
Par contre tu me dis que la led verte doit resté allumée ??
Jamais elle est restée allumée, elle clignote differement mais elle clignote toujours !
Sur les Digikeijs il est y a une petite led orange entre les connecteurs R-BUS, qui soi-disant quand elle est allumée témoigne que le module est "adressé", mais j'ai pas trouvé sur la doc, qu'ils écrivent que la led verte ne doit plus clignoter quand le module est bien adressé ?
Néanmois sur le z21 Maintenance, quand une loco passe d'un module à un autre les valeurs inscrites à 8 chiffres varient mais j'ai remarqué que c'est pas trés flagrant et systématique.
Je me demande si ce n'est pas ma centrale qui "voit" les modules mais pas leurs cantons ?
Qui ne renvoi pas l'info des modules ?
Pour l'instant des questions sans réponses...

Avatar du membre
Coquelicot94
Expansif
Messages : 2365
Enregistré le : lun. 02 janv. 2006, 17:21
Echelle pratiquée : H0
Localisation : Maroeuil (62)
Âge : 67

Re: Rétrosignalisation Roco, Digikeijs

Message par Coquelicot94 » mar. 14 janv. 2020, 20:07

Je pense que tu te trompes dans la prog des modules 4088RB CS. Par défaut le 1er est à l'adresse 1 et cela suffit pour les 2 X 8 sorties. Ensuite le 2ème module il faut lui donner l'adresse 3 et c'est tout, il est prêt pour les sorties 3 et 4.
A suivre...
HO, N, Roco MMpro, zZ21, TC V9

Avatar du membre
Pat06
Messages : 10
Enregistré le : mer. 20 nov. 2019, 19:25
Echelle pratiquée : N
Prénom : Pat
Club : AMFN
Localisation : Sud Est

Re: Rétrosignalisation Roco, Digikeijs

Message par Pat06 » mer. 15 janv. 2020, 13:00

De Coquelicot94
► Afficher le texte
Peut être, donc j'ai refait l'adressage comme tu me le décrit.
C'est idem, les led rouges de 2 modules détectent bien ma loco sur le passage des cantons qui leur appartiennent, mais sur le TCO de Windigipet c'est parfois d'autres cantons qui s'allument à l'autre bout du réseau et qui sont gérer par les Roco.
A noter que quand ma loco passe sur des cantons appartenant aux Roco ça fait la même chose... :?

Avec les conseils d'un ami à l'autre bout de la France qui possède Windigipet mais qui lui à du Lenz/Xpress-Net, j'ai adressé le 1er Roco 10808 avec l'adresse 1 d'ou part le 1er canton N°1 et j'ai placé ma loco sur celui la. Résultat : le canton sur WDP ne s'allume pas, (sauf bien sur sur la led du module lui même),c'est le canton 8 qui s'allume sur WDP et cela même si je retire la loco des rails ! :siffle:
Rien de cohérent donc.
J'ai le sentiment que ça peut venir de ma z21 Start, qui renvoi pas les infos, enfin quelque chose qui déconne chez elle... :roll:
Mais la c'est difficile à tester.
Néanmoins samedi à mon club (AMFN) je vais apporter 1 Digikeijs et 1 Roco a un ami qui connait bien l'électronique et qui possède une DR5000, chez lui à l'aide de l'interface de Digikeijs qui est plus complète que celle de Roco (la mienne), il va tester et adressé ces 2 modules pour voir ensuite sur mon réseau si ça change quelque chose...
Merci pour tes conseils Coquelicot94. :)

Avatar du membre
Coquelicot94
Expansif
Messages : 2365
Enregistré le : lun. 02 janv. 2006, 17:21
Echelle pratiquée : H0
Localisation : Maroeuil (62)
Âge : 67

Re: Rétrosignalisation Roco, Digikeijs

Message par Coquelicot94 » mer. 15 janv. 2020, 13:12

Bonjour, comme tu le décris cela semble être un problème d’adressage sous ton logiciel (que je ne connais pas)..
A+
HO, N, Roco MMpro, zZ21, TC V9

philho
Éloquent
Messages : 310
Enregistré le : lun. 01 févr. 2010, 19:00

Re: Rétrosignalisation Roco, Digikeijs

Message par philho » mer. 15 janv. 2020, 18:24

Comme vous avez bien lu la notice du DR4088RB-CS, il ne vous a pas échapper que l'on peut connecter des module DR4088 (donc s88) sur un DR4088RB-CS. Le DR4088RB-CS sert "d'interface" entre le bus s88 et le R-bus.

Lors de la programmation d'un DR4088RB-CD, le premier paramètre à programmer est l'adresse du module.
Le deuxième paramètre à programmer est le nombre de modules:
égale à 2 pour le DR4088RB-CS + 2 pour chaque DR4088 "s88" connectés. Si il n'y en a pas (et c'est votre cas) il faut bien sur mettre 2 comme le dit la notice (page 7)

Donc pour la programmation des DR4088RB-CS:
- Pour premier module DR4088RB-CS: adresse = 1, Nb de module = 2
- Pour le second DR4088RB-CS: adresse = 3, Nb de module = 2

Si vous programmer autre chose que 2 pour le nombre de modules, il va y avoir conflit d'adressage et ça va pas bien se passer.
Donc si vous avez mis 4 dans le deuxième paramètres du deuxième modules, il va répondre aux 4 adresses consécutive 3, 4, 5 et 6 et il va y avoir un conflit avec les 2 premiers modules 10808.

Si la LED verte continue à clignoter, c'est que la programmation n'a pas été prise en compte par le module.

Attention, la première version de la notice du DR4088RB-CS est bourrée d'erreurs, il faut bien prendre la dernière version, là (tout en bas):
https://www.boutique-train.fr/digikeijs ... 61669.html

Répondre