commande permanente en commande impulsionnelle

Ici, c'est l'électricité, l'électronique, l'alimentation - analogique ou "digitale" - etc.

Modérateur : MOD

Répondre
Avatar du membre
Rail76
Causant
Messages : 297
Enregistré le : mer. 26 oct. 2005, 15:59
Site Internet : http://perso.wanadoo.fr/rail76/
Localisation : Haute Normandie
Âge : 60

commande permanente en commande impulsionnelle

Message par Rail76 » dim. 25 nov. 2007, 18:31

Bonsoir à tous

j'ai réalisé un montage permettant de transformer une commande permanente en commande impulsionnelle pour aiguillage .
ce montage provient du loco revue N° 559 de mai93 et dont voici le schéma

ce n'est pas mon premier montage électronique pour ceux qui me connaisse
le schéma est pourtant trés simple et je mis connais bien
mais là je coince un schéma si simple pourtant !.
le Circuit imprimé est bien réalisé pas de court circuit ni d'inversion de branchement de transistor ou autre
j'aimerais savoir si parmis vous certain on déja réalisé ce montage et si il fonctionne , ou si il y a une petite erreur de schema que je n'aurais pas vue
Merci de votre aide
Marc

Avatar du membre
obones
Papotier
Messages : 188
Enregistré le : mar. 15 août 2006, 23:03
Site Internet : http://www.obones.com/
Localisation : Lyon
Âge : 38

Message par obones » dim. 25 nov. 2007, 19:48

Tout ça pour ça ?
Un simple RC et on a l'impulsion. Bon certes, elle est pas carrée, mais dans le domaine du modélisme, je doute que ça ait un impact quelconque. Et puis bon, si faut vraiment la mettre en forme, un simple trigger de schmitt fera l'affaire.

Avatar du membre
Rail76
Causant
Messages : 297
Enregistré le : mer. 26 oct. 2005, 15:59
Site Internet : http://perso.wanadoo.fr/rail76/
Localisation : Haute Normandie
Âge : 60

Message par Rail76 » lun. 26 nov. 2007, 08:04

cela n'a pas répondu à ma question .

si encore il y avait un petit schéma joint , pour cette nouvelle proposition!!.

mais bon je peux comprendre que le sujet n'interesse pas même si dans certain cas ce montage est bien utile .

ce n'est pas grave je vais me débrouiller autrement

Merci

Avatar du membre
Trains'N Cie
Ma panne s'effrite
Messages : 2791
Enregistré le : ven. 26 août 2005, 11:28
Localisation : Ex toulousain
Âge : 37

Message par Trains'N Cie » lun. 26 nov. 2007, 09:39

N'existe-t-il pas des interrupteurs qui ont cette fonctionnalité: ils restent dans une position permanante mais au passage ne donne qu'une impulsion?...
Daniel. Je suis donc je pense.

Avatar du membre
obones
Papotier
Messages : 188
Enregistré le : mar. 15 août 2006, 23:03
Site Internet : http://www.obones.com/
Localisation : Lyon
Âge : 38

Message par obones » lun. 26 nov. 2007, 09:41

Beh tu ne dis pas ce que tu observes et ce que tu voudrais, donc j'ai du mal à apporter une réponse précise à une question que je ne peux que deviner.

Quant au montage que je propose, voici :

Code : Tout sélectionner

       In
        |
       ---
       ---
        |              |\    |\
        +----->|-------|S>O--|S>O----- Out
        |              |/    |/
       .-.
       | |
       | |
       '-'
        |
       GND

(created by AACircuit v1.28.6 beta 04/19/05 www.tech-chat.de)
La diode est là pour protéger le trigger de schmitt lors de la décharge du condensateur. En effet, dans ce cas là, la tension aux bornes de la résistance est négative (-Vin) et détruirait donc le circuit.
Note que ce montage fait une impulsion sur un front montant présent sur In et que la durée de cette impulsion dépend directement de la constante RC.
Et puis j'ai mis deux portes NON en cascade parce que les triggers de schmitt se trouvent tout fait dans les portes NON (le 74xx14 en contient 6)

Avatar du membre
Rail76
Causant
Messages : 297
Enregistré le : mer. 26 oct. 2005, 15:59
Site Internet : http://perso.wanadoo.fr/rail76/
Localisation : Haute Normandie
Âge : 60

Message par Rail76 » lun. 26 nov. 2007, 10:41

je crois que l'on ne sais pas bien compris .
en régle général les moteurs d'aiguillage Type Roco ou Peco sont commander par un poussoir fugitif délivrant une impulsion bréve .

dans le cas présent il s'agit de finir l'automatisation de la commande d'une boucle de retournement qui pour l'instant voie le changement de position de l'aiguille par de simple poussoir fugitif.
l'aiguillage est déja équipé sur son moteur péco d'un double inverseur pour l'inversion du courant au moment du retour de boucle .
le dernier canton avant la sortie de boucle est équipé d'un détecteur à consommation de courant , quand la machine entre sur ce canton elle est détectée et commande un relais et je veux qu' a partir de ce contact de relais pouvoir générer une simple impulsion pour commander l'aiguillage afin que le train puisse sortir ,une fois le dernier wagon sortie fin de détection le relais se décolle et le contact repos dois a nouveau commander un circuit ne générant qu'une impulsion pour permettre a nouveau à l'aiguillage de ce mettre en position entrée même si le contact reste fermée une impulsion est une seul .

j'espére avoir été plus moins confus !

le schéma que j'ai présenté en début me plaisait bien mais il semble qu'il ne fonctionne pas les bobines grogne comme si il y avait un courant permanent et la 120 ohm de T2 chauffe même sans la présence du moteur
je suis certain de mon cablage et de mes composants à savoir si il ni a pas une petite erreur sur le schéma ?

Avatar du membre
obones
Papotier
Messages : 188
Enregistré le : mar. 15 août 2006, 23:03
Site Internet : http://www.obones.com/
Localisation : Lyon
Âge : 38

Message par obones » lun. 26 nov. 2007, 11:09

Je vois ton application, et je la comprends bien, j'ai les mêmes moteurs d'aiguillage sur mon réseau (Marklin)
Pour ton montage d'origine, je pense qu'il y'a un problème avec. Si j'ai bien suivi, le 12V arrive sur la base de T2 via la résistance de 47k. Le transistor est donc passant et le courant peut donc circuler depuis le +12 vers la masse au travers de la 120ohms et T2.
Donc pour moi, au repos, le montage consomme du courant pour rien, et pas qu'un peu, puisqu'on a au minimum 2 * 12 / 120 = 200 mA
En fait, ce montage là fait une impulsion vers le 0 dès qu'un changement arrive sur l'interrupteur mais au repos, sa sortie est au +12.
Celui que je te propose fait exactement l'inverse. Bon, il est simpliste parce qu'il ne prend pas en compte les tensions max et le courant demandé en sortie, mais il présente le principe de base.
Reste à l'adapter via un pont diviseur de tension en entrée et un mosfet (ou un transistor) en sortie.
Je suis au boulot là, alors j'ai pas les outils pour te faire les diagrammes, mais l'idée de base est de se servir de la charge d'un condensateur au travers d'une résistance pour obtenir le "pic".

Avatar du membre
PN118
Messages : 23
Enregistré le : mar. 26 déc. 2006, 14:04

Message par PN118 » mar. 27 nov. 2007, 13:07

Pour ton montage d'origine, je pense qu'il y'a un problème avec. Si j'ai bien suivi, le 12V arrive sur la base de T2 via la résistance de 47k. Le transistor est donc passant et le courant peut donc circuler depuis le +12 vers la masse au travers de la 120ohms et T2.
Donc pour moi, au repos, le montage consomme du courant pour rien, et pas qu'un peu, puisqu'on a au minimum 2 * 12 / 120 = 200 mA
En fait, ce montage là fait une impulsion vers le 0 dès qu'un changement arrive sur l'interrupteur mais au repos, sa sortie est au +12.
Au repos le transistor BC 237c devrait être saturé (tension collecteur - émetteur proche de 0 volt) et de ce fait "bloquer " le BD165. On peut estimer ici le courant collecteur de chaque BC237 à 0,1 ampère au repos (!) (la résistance de 120 ohms dissipe 1,2 watts.. "c'est pas bon pour la Planète" ... )

Avec 47 Kohms dans la base le gain en courant doit être de l'ordre de 400 ! Si le BC237C n' a pas assez de gain (la lettre C dans la référence a son importance) il ne se sature pas complètement et laisse donc conduire le transistor BD165 :(

Suggestion (à tester) : remplacer la résistance de 47 Kohms dans la base de chaque BC237 par une résistance de 10 Kohms . Il faudra aussi augmenter la valeur du condensateur (100 uF ou + ) :wink:

( Sinon il existe un schéma plus simple et plus efficace à base de transistor "Darlington" style TIP122 mais je n'arrive plus à retrouver son lien ... :colere: )


:siffle:

Avatar du membre
obones
Papotier
Messages : 188
Enregistré le : mar. 15 août 2006, 23:03
Site Internet : http://www.obones.com/
Localisation : Lyon
Âge : 38

Message par obones » mar. 27 nov. 2007, 13:21

Mais surtout, en regardant le schéma en détail, on voit un créneau dessiné sur la sortie. Et ce créneau est bien avec un état bas pendant une durée T. Hors ce qu'on cherche ici c'est un état haut avec une durée T...

Avatar du membre
Rail76
Causant
Messages : 297
Enregistré le : mer. 26 oct. 2005, 15:59
Site Internet : http://perso.wanadoo.fr/rail76/
Localisation : Haute Normandie
Âge : 60

Message par Rail76 » mar. 27 nov. 2007, 13:36

ce schéma provient d'un loco revue de Mai 93 N° 559
j'ai regarder voire si il ni avait pas d'erratum dans les N° 560 et 561 et rien .

au niveau des transistors T1 / T2 j'ai employé des BC 547 C
et au niveau de T3 / T4 des BD 237

le schéma est pourtant simple et j'ai du mal à comprendre son disfonctionnement

sinon il faudra que je trouve un autre schéma , mais je n'aime pas rester sur un échec et surtout ne pas comprendre

Avatar du membre
PN118
Messages : 23
Enregistré le : mar. 26 déc. 2006, 14:04

Message par PN118 » mar. 27 nov. 2007, 13:59

Mais surtout, en regardant le schéma en détail, on voit un créneau dessiné sur la sortie. Et ce créneau est bien avec un état bas pendant une durée T. Hors ce qu'on cherche ici c'est un état haut avec une durée T...
Le créneau est dans le bon sens (il représente la tension collecteur émetteur de T3 ou T4) .

Attention le commun du moteur des aiguilles est ici relié au + 12 volts :P

Si le BC 237 est bien saturé (avec un Vce # 0 ) T3 (ou T4) est bloqué et on retrouve le 12 volts (niveau haut) sur le collecteur de T3 (ou T4). Quand T3 (ou T4) conduit il ramène un "zéro volt" (niveau bas ) , durant la durée T . En résumé T3 (T4) joue le rôle d'un interrupteur relié d'un côté à la masse et de l'autre à une bobine elle même reliée au +12v ...

:wink:

Répondre