Besoin d'aide pour de l'arduino

Toutes les discussions sur l'Arduino !

Modérateur : MOD

Avatar du membre
Gauth87
Messages : 41
Enregistré le : lun. 09 avr. 2018, 21:40
Echelle pratiquée : Ho
Prénom : Gauthier
Localisation : Versailles
Âge : 17

Re: Besoin d'aide pour de l'arduino

Message par Gauth87 » lun. 28 oct. 2019, 15:39

Bonjour à tous,
Un très grand merci pour votre aide, j'ai réussi à adapter le programme, le fonctionnement est absolument impeccable et correspond tout à fait à ce que je voulais faire.
J'ai fait un montage à blanc et préparé le TCO, ça va être super!
Je vais essayer avec les interrupteurs du TCO de contrôler les leds des signaux.
Bonne après midi
Gauth87
Gauthier

Vive le Limousin

Plume
Bavard
Messages : 74
Enregistré le : jeu. 02 juil. 2015, 22:18
Echelle pratiquée : HO
Club : UAICF Nevers Vauzelles
Site Internet : http://modelisme58.free.fr
Localisation : Nevers

Re: Besoin d'aide pour de l'arduino

Message par Plume » mar. 29 oct. 2019, 13:01

Les condensateurs C1 à C6 ne sont pas obligatoires. Je ne les mets plus sur la carte.
De même que les résistances R5 à R10.

J'avais prévu ces composants au cas où.

Pour le bornier JP3, il était prévu au départ pour mettre un potentiomètre pour trouver les angles mini et maxi à rentrer dans le programme.

Avatar du membre
Gauth87
Messages : 41
Enregistré le : lun. 09 avr. 2018, 21:40
Echelle pratiquée : Ho
Prénom : Gauthier
Localisation : Versailles
Âge : 17

Re: Besoin d'aide pour de l'arduino

Message par Gauth87 » mar. 29 oct. 2019, 18:54

C'est bon, c'est fini pour les signaux, après plusieurs heures passées à quatre pattes sous le réseau.
Le rendu est excellent, fonctionnement silencieux et réaliste :coeur1:
Je n'ai pas mis de condensateurs, ni de résistances, ni d'interrupteur pour sélectionner analogique ou digital, et aucun problèmes.
Quelques photos où l'on distingue l'un des 4 carrés:
Un x2800 arrivant de Limoges entre en gare de Chassagne
2019-10-29-18-40-43-640x480.jpg
2019-10-29-18-40-43-640x480.jpg (82.6 Kio) Vu 1442 fois
Un x2800 arrivant d'Ussel quittant la gare de Chassagne
2019-10-29-18-39-02-640x480.jpg
2019-10-29-18-39-02-640x480.jpg (71.9 Kio) Vu 1442 fois
Gauthier

Vive le Limousin

Avatar du membre
Gauth87
Messages : 41
Enregistré le : lun. 09 avr. 2018, 21:40
Echelle pratiquée : Ho
Prénom : Gauthier
Localisation : Versailles
Âge : 17

Modification de signaux mécaniques motorisés par Arduino

Message par Gauth87 » jeu. 26 mars 2020, 11:53

Bonjour à tous,
Je rouvre ce fil car je souhaiterai modifier et améliorer mes signaux mécaniques.
Cet hiver, mon réseau est resté dans une grange, le système Arduino et servomoteur a survécu (à mon grand étonnement), mais des petits rongeurs on pris un malin plaisir a manger les câbles :colere: :colere: .
Lors de la remise en service(plus tôt que prévu grâce au confinement), je cherchai un moyen de rajouter des LEDs CMS/SMD sur mes signaux mécaniques (pour l'instant je n'ai que des rouges).

Petit rappel: Les signaux commutent grâce a des interrupteurs à glissière et un programme fourni par DeepPurple.
Il y en a 4, 2 carrés "classique" et 2 carrés violet.

Ce que j'imaginais est de brancher les LEDs sur les mêmes interrupteurs, branchés sur la borne négative.
Voici un petit schéma, en espérant qu'il soit compréhensible.
20200326_113820_copy_1548x2064[1].jpg
Je ne pense pas qu'il y ai besoin de modifier le programme. Est-ce mieux de se connecter sur le 5V ou sur le 3,3V?
Merci d'avance pour vos réponse et votre aide

Ferroviairement

Gauthier
Gauthier

Vive le Limousin

Plume
Bavard
Messages : 74
Enregistré le : jeu. 02 juil. 2015, 22:18
Echelle pratiquée : HO
Club : UAICF Nevers Vauzelles
Site Internet : http://modelisme58.free.fr
Localisation : Nevers

Re: Besoin d'aide pour de l'arduino

Message par Plume » jeu. 26 mars 2020, 20:42

Bonjour,

Une connexion sur le +5V et je proposerai de mettre une résistance pour chaque LED.
On peut mettre les résistances reliées à la masse (gnd) (fils vert et rouge) et disposer d'un fil commun au +5V.

Avatar du membre
Gauth87
Messages : 41
Enregistré le : lun. 09 avr. 2018, 21:40
Echelle pratiquée : Ho
Prénom : Gauthier
Localisation : Versailles
Âge : 17

Re: Besoin d'aide pour de l'arduino

Message par Gauth87 » ven. 27 mars 2020, 09:47

Merci Plume!
Plume a écrit :
jeu. 26 mars 2020, 20:42
Une connexion sur le +5V et je proposerai de mettre une résistance pour chaque LED.
Je imaginais en effet faire ça, ça m'enlève le doute entre l'utilisation du 5V ou du 3,3V. Ça donnerait donc: récupérer le 5V au niveau d'un domino placé à la sortie de la carte Arduino, mais par contre utiliser 1 résistance pour toutes les Leds rouges d'un même signal (Les Leds CMS non soudé, c'est un petit peu énervant a souder, donc je les soude directement sur la tige de la résistance). Puis pour la borne négative, venir la prendre directement sur l'interrupteur.
Plume a écrit :
jeu. 26 mars 2020, 20:42
On peut mettre les résistances reliées à la masse (gnd) (fils vert et rouge) et disposer d'un fil commun au +5V.
La résistance, il faut normalement la mettre sur la borne positive.
Je vais faire des essais aujourd'hui, si je trouve le temps.

Gauthier
Gauthier

Vive le Limousin

Plume
Bavard
Messages : 74
Enregistré le : jeu. 02 juil. 2015, 22:18
Echelle pratiquée : HO
Club : UAICF Nevers Vauzelles
Site Internet : http://modelisme58.free.fr
Localisation : Nevers

Re: Besoin d'aide pour de l'arduino

Message par Plume » ven. 27 mars 2020, 13:32

J'éviterai les dominos : on peut utiliser des platines d'essai et de souder les fils et broches qui viennent s'enfiler dans la carte Arduino.

Je joins un exemple pour un capteur que j'ai sous la main.
broches_A.jpg
broches_A.jpg (26.76 Kio) Vu 179 fois
broches_B.jpg
broches_B.jpg (31.47 Kio) Vu 179 fois
On peut mettre les résistances au +5 V ou à la masse. Il n'y a pas de sens.

Avatar du membre
Gauth87
Messages : 41
Enregistré le : lun. 09 avr. 2018, 21:40
Echelle pratiquée : Ho
Prénom : Gauthier
Localisation : Versailles
Âge : 17

Re: Besoin d'aide pour de l'arduino

Message par Gauth87 » ven. 27 mars 2020, 20:47

Plume a écrit :
ven. 27 mars 2020, 13:32
J'éviterai les dominos : on peut utiliser des platines d'essai et de souder les fils et broches qui viennent s'enfiler dans la carte Arduino.
Étant parti sans trop réfléchir a quoi prendre, je n'ai pas pris de plaques de Bakélite, bon, pour l'instant les dominos, ça fonctionne correctement, bon le câblage est quelque peu bordélique :siffle: .
Bon sinon, j'ai réussi à faire des tests, ce que j'ai fait fonctionne, je me suis mis pour commencer sur le 5V, mais les Leds éclairaient trop puissamment, donc je me suis mis sur le 3,3V et c'est mieux, montage basique mais très efficace.
20200327_190024_copy_1651x1238.jpg
20200327_172137_copy_1651x2201_copy_825x1100.jpg
Gauthier

Vive le Limousin

Répondre